通达信副图指标-市盈率强化版

  • 栏目:欧宝品牌 时间:2021-06-06 16:43 分享新闻到:
<返回列表

昨天的动态市盈率公式有点题目,不该该行使 FINANCE(33) 函数,昨天留言有说,但是不安许多至交异国望到,以是今天把修改后的公式重新发布一下。

起伏市盈率指标公式不变,只修改了动态市盈率指标公式。

行家有公式方面的题目请在留言区留言,不要在公多号直接发私信啦!

倘若公式有什么题目吾也会留言置顶。

五一伪期转眼就只剩下镇日了,行家休休的可益。明天大A就要开盘了,惊不惊喜,意意外表

图片

这个五一吾也出往瞎晃了两天,以是除了1号给行家推了一篇公式相符集,后面几天都没更新了。

不过节前在起伏市盈率那篇说了五一会钻研一下市盈率的公式,这个照样没遗忘的,今天就给行家分享一下市盈率强化版。

再强调一下,后面正文内里就不每篇都挑醒了,行家最益养成习气,每天先更新一下财务数据再望公式

挑醒:本公式行使了财务函数,必要先下载【专科财务数据】

下载流程:【体系】-【专科财务数据】-【最先下载】

前线不少至交提出添上动态市盈率,这次吾就把起伏市盈率和动态市盈率的公式都写了一下,分了两个指标,行家行使的时候记得要建两个公式,不要混到一首了。

其实,倘若只是仅仅把起伏市盈率和动态市盈率放在一个副图也能够,但是添了其他画线的数据一首,线就太多了,比较乱,这也是为什么吾要分两个副图指标。

先上几张成绩图

日线周期

图片

周线周期

图片

月线周期

图片

起伏市盈率(TTM)指标公式:

==============================================

净利润TTM := FINVALUE(276), NODRAW; {近一年净利润}

总市值 := FINVALUE(238)*C, NODRAW;

市盈率TTM : IF(净利润TTM>0, 总市值/净利润TTM, 0), COLORYELLOW, LINETHICK2;

{周期数}

PCOUNT := IF(PERIOD = 7, 120, IF(PERIOD = 6,欧宝品牌 500, 2500));

MCOUNT := IF(TOTALBARSCOUNT>PCOUNT,PCOUNT,TOTALBARSCOUNT);

近10年最大 : HHV(市盈率TTM, MCOUNT), COLORYELLOW, LINETHICK1;

近10年最幼 : IF(LLV(市盈率TTM, MCOUNT)<0, 0, LLV(市盈率TTM, MCOUNT )), COLORYELLOW, LINETHICK1;

现在平均值  := SUM(IF(市盈率TTM<0,0,市盈率TTM), MCOUNT)/MCOUNT;

近10年平均  : DRAWLINE(CURRBARSCOUNT=MCOUNT, CONST(现在平均值), CURRBARSCOUNT=1, 现在平均值, 3), COLORGREEN, DOTLINE;

近10年百分位 : (市盈率TTM - 近10年最幼)/(近10年最大 - 近10年最幼), NODRAW;

==============================================

动态市盈率指标公式:

==============================================

通知期 := FINVALUE(0) - INTPART(FINVALUE(0)/10000)*10000, NODRAW;

每股利润 : IF(通知期=331, FINVALUE(1)*4, IF(通知期=630, FINVALUE(1)*2, IF(通知期=930, FINVALUE(1)*4/3, FINVALUE(1)))), NODRAW;

动态市盈率 : IF(C/每股利润<0, 0, C/每股利润), COLORRED, LINETHICK2;

{周期数}

PCOUNT := IF(PERIOD = 7, 120, IF(PERIOD = 6, 500, 2500));

MCOUNT := IF(TOTALBARSCOUNT>PCOUNT,PCOUNT,TOTALBARSCOUNT);

近10年最大 : HHV(动态市盈率, MCOUNT), COLORRED, LINETHICK1;

近10年最幼 : IF(LLV(动态市盈率, MCOUNT)<0, 0, LLV(动态市盈率, MCOUNT)), COLORRED, LINETHICK1;

现在平均值  := SUM(IF(动态市盈率<0,0,动态市盈率), MCOUNT)/MCOUNT;

近10年平均  : DRAWLINE(CURRBARSCOUNT=MCOUNT, CONST(现在平均值), CURRBARSCOUNT=1, 现在平均值, 3), COLORGREEN, DOTLINE;

近10年百分位 : (动态市盈率 - 近10年最幼)/(近10年最大 - 近10年最幼), NODRAW;

走业市盈率 : HYSYL, NODRAW;

==============================================

浅易注释一下:

计算最大、最幼、平均值吾行使的是近10年的数据。由于历史太悠久的,不具备参考性了。行家要是10年还嫌长的,能够本身修改周期数 PCOUNT。

这两个公式周期一时都只声援日线、周线、月线,想添其他周期的能够本身判定一下PERIOD 的值,然后赋值给 PCOUNT。

近10年平均,由于日线、周线、月线计算的值是纷歧样的,是由于这个平均值是用周期末了一日的市盈率相添除以周期数计算出来的,以是差别周期计算会有谬误。

日线是每天的收盘价数据计算平均值,周线是每周收盘价数据计算的,月线是每月的收盘价计算的。

这边,计算最精准的答该是日线。

正本还想添一个现在价格别离对答异日两年的市盈率,但是展望异日两年的净利润的数据一时还没搞定,以是就没添上了。后面吾钻研出来了会分享出来的。

迎接行家 留言、点赞、珍藏、转发!

这个教程要是对你有协助,右下角帮吾点个“在望”就是对吾的声援了!

分享新闻到:

更多阅读

通达信主图指标

欧宝品牌 2021-06-13
图片 指标源码: N:=5;M:=13; 上:EMA(C,3),COLORRED,LINETHICK1; 中:EMA(C,5),COLOR00FF00,LINETHICK1; 下:EMA(中,5),...
查看全文

股市:军工板块悄然兴首!机构高关注的

欧宝品牌 2021-06-06
军工板块兴首A股市场常言:“最大的益处抵不过价高,最大的利空抵不过价矮。”近期上证指...
查看全文

涨停基因手段——过左三峰的思想导图,

欧宝品牌 2021-06-06
从量柱角度望,有微添量过左三峰、平量过左三峰、倍量过左三峰、缩量过左三峰、梯量过左...
查看全文


Powered by 欧宝体育最新网 @2018 RSS地图 HTML地图

2013-2021 168ty 版权所有